Security Wireless

Linksys WRT54G Router Remote Administration apply.cgi Buffer Overflow Vulnerabil

News / Bug
Inviato da Admin 14 Set 2005 - 11:00

E' stata riscontrato un buffer overflow in diverse versioni del firmaware del prodotto Linksys WRT54G che potrebbe permettere ad un remote user di eseguire comandi con permessi da root.



La vulnerabilitÓ esisterebbe nel file 'apply.cgi', che permetterebbe ad un remote non autenticato attacker eseguendo una richeista POST con piu di 1000 byte di mandare in buffer overflow.

Sfruttando inoltre questa vulnerabilitÓ sarebbe possibile poter eseguire codice sul device con permessi da root.

Versioni vulnerabili:

3.01.03 - 3.03.6. Tutte le versioni < 4.20.7 potrebbero essere affette

Soluzione:
Upgradare alla 4.20.7
http://www.linksys.com/servlet/Satellite?childpagename=US%2FLayout&packedargs=c%3DL_Download_C2&cid%3D1115417109974&sku%3D1124916802645&pagename=Linksys%2FCommon%2FVisitorWrapper


Questo articolo Ŕ stato inviato da Security Wireless
  http://www.securitywireless.info/

La URL di questo articolo Ŕ:
  http://www.securitywireless.info/modules.php?op=modload&name=News&file=article&sid=115